Home | History | Annotate | Line # | Download | only in dist
      1 
      2   NEWS
      3   ====
      4 
      5   This file gives a brief overview of the major changes between each OpenSSL
      6   release. For more details please read the CHANGES file.
      7 
      8   Major changes between OpenSSL 1.1.1s and OpenSSL 1.1.1t [7 Feb 2023]
      9 
     10       o Fixed X.400 address type confusion in X.509 GeneralName (CVE-2023-0286)
     11       o Fixed Use-after-free following BIO_new_NDEF (CVE-2023-0215)
     12       o Fixed Double free after calling PEM_read_bio_ex (CVE-2022-4450)
     13       o Fixed Timing Oracle in RSA Decryption (CVE-2022-4304)
     14 
     15   Major changes between OpenSSL 1.1.1r and OpenSSL 1.1.1s [1 Nov 2022]
     16 
     17       o Fixed a regression introduced in OpenSSL 1.1.1r not refreshing the
     18         certificate data to be signed before signing the certificate.
     19 
     20   Major changes between OpenSSL 1.1.1q and OpenSSL 1.1.1r [11 Oct 2022]
     21 
     22       o Added a missing header for memcmp that caused compilation failure on
     23         some platforms
     24 
     25   Major changes between OpenSSL 1.1.1p and OpenSSL 1.1.1q [5 Jul 2022]
     26 
     27       o Fixed AES OCB failure to encrypt some bytes on 32-bit x86 platforms
     28         (CVE-2022-2097)
     29 
     30   Major changes between OpenSSL 1.1.1o and OpenSSL 1.1.1p [21 Jun 2022]
     31 
     32       o Fixed additional bugs in the c_rehash script which was not properly
     33         sanitising shell metacharacters to prevent command injection
     34         (CVE-2022-2068)
     35 
     36   Major changes between OpenSSL 1.1.1n and OpenSSL 1.1.1o [3 May 2022]
     37 
     38       o Fixed a bug in the c_rehash script which was not properly sanitising
     39         shell metacharacters to prevent command injection (CVE-2022-1292)
     40 
     41   Major changes between OpenSSL 1.1.1m and OpenSSL 1.1.1n [15 Mar 2022]
     42 
     43       o Fixed a bug in the BN_mod_sqrt() function that can cause it to loop
     44         forever for non-prime moduli (CVE-2022-0778)
     45 
     46   Major changes between OpenSSL 1.1.1l and OpenSSL 1.1.1m [14 Dec 2021]
     47 
     48       o None
     49 
     50   Major changes between OpenSSL 1.1.1k and OpenSSL 1.1.1l [24 Aug 2021]
     51 
     52       o Fixed an SM2 Decryption Buffer Overflow (CVE-2021-3711)
     53       o Fixed various read buffer overruns processing ASN.1 strings (CVE-2021-3712)
     54 
     55   Major changes between OpenSSL 1.1.1j and OpenSSL 1.1.1k [25 Mar 2021]
     56 
     57       o Fixed a problem with verifying a certificate chain when using the
     58         X509_V_FLAG_X509_STRICT flag (CVE-2021-3450)
     59       o Fixed an issue where an OpenSSL TLS server may crash if sent a
     60         maliciously crafted renegotiation ClientHello message from a client
     61         (CVE-2021-3449)
     62 
     63   Major changes between OpenSSL 1.1.1i and OpenSSL 1.1.1j [16 Feb 2021]
     64 
     65       o Fixed a NULL pointer deref in the X509_issuer_and_serial_hash()
     66         function (CVE-2021-23841)
     67       o Fixed the RSA_padding_check_SSLv23() function and the RSA_SSLV23_PADDING
     68         padding mode to correctly check for rollback attacks
     69       o Fixed an overflow in the EVP_CipherUpdate, EVP_EncryptUpdate and
     70         EVP_DecryptUpdate functions (CVE-2021-23840)
     71       o Fixed SRP_Calc_client_key so that it runs in constant time
     72 
     73   Major changes between OpenSSL 1.1.1h and OpenSSL 1.1.1i [8 Dec 2020]
     74 
     75       o Fixed NULL pointer deref in GENERAL_NAME_cmp (CVE-2020-1971)
     76 
     77   Major changes between OpenSSL 1.1.1g and OpenSSL 1.1.1h [22 Sep 2020]
     78 
     79       o Disallow explicit curve parameters in verifications chains when
     80         X509_V_FLAG_X509_STRICT is used
     81       o Enable 'MinProtocol' and 'MaxProtocol' to configure both TLS and DTLS
     82         contexts
     83       o Oracle Developer Studio will start reporting deprecation warnings
     84 
     85   Major changes between OpenSSL 1.1.1f and OpenSSL 1.1.1g [21 Apr 2020]
     86 
     87       o Fixed segmentation fault in SSL_check_chain() (CVE-2020-1967)
     88 
     89   Major changes between OpenSSL 1.1.1e and OpenSSL 1.1.1f [31 Mar 2020]
     90 
     91       o Revert the unexpected EOF reporting via SSL_ERROR_SSL
     92 
     93   Major changes between OpenSSL 1.1.1d and OpenSSL 1.1.1e [17 Mar 2020]
     94 
     95       o Fixed an overflow bug in the x64_64 Montgomery squaring procedure
     96         used in exponentiation with 512-bit moduli (CVE-2019-1551)
     97       o Properly detect unexpected EOF while reading in libssl and report
     98         it via SSL_ERROR_SSL
     99 
    100   Major changes between OpenSSL 1.1.1c and OpenSSL 1.1.1d [10 Sep 2019]
    101 
    102       o Fixed a fork protection issue (CVE-2019-1549)
    103       o Fixed a padding oracle in PKCS7_dataDecode and CMS_decrypt_set1_pkey
    104         (CVE-2019-1563)
    105       o For built-in EC curves, ensure an EC_GROUP built from the curve name is
    106         used even when parsing explicit parameters
    107       o Compute ECC cofactors if not provided during EC_GROUP construction
    108         (CVE-2019-1547)
    109       o Early start up entropy quality from the DEVRANDOM seed source has been
    110         improved for older Linux systems
    111       o Correct the extended master secret constant on EBCDIC systems
    112       o Use Windows installation paths in the mingw builds (CVE-2019-1552)
    113       o Changed DH_check to accept parameters with order q and 2q subgroups
    114       o Significantly reduce secure memory usage by the randomness pools
    115       o Revert the DEVRANDOM_WAIT feature for Linux systems
    116 
    117   Major changes between OpenSSL 1.1.1b and OpenSSL 1.1.1c [28 May 2019]
    118 
    119       o Prevent over long nonces in ChaCha20-Poly1305 (CVE-2019-1543)
    120 
    121   Major changes between OpenSSL 1.1.1a and OpenSSL 1.1.1b [26 Feb 2019]
    122 
    123       o Change the info callback signals for the start and end of a post-handshake
    124         message exchange in TLSv1.3.
    125       o Fix a bug in DTLS over SCTP. This breaks interoperability with older versions
    126         of OpenSSL like OpenSSL 1.1.0 and OpenSSL 1.0.2.
    127 
    128   Major changes between OpenSSL 1.1.1 and OpenSSL 1.1.1a [20 Nov 2018]
    129 
    130       o Timing vulnerability in DSA signature generation (CVE-2018-0734)
    131       o Timing vulnerability in ECDSA signature generation (CVE-2018-0735)
    132 
    133   Major changes between OpenSSL 1.1.0i and OpenSSL 1.1.1 [11 Sep 2018]
    134 
    135       o Support for TLSv1.3 added (see https://wiki.openssl.org/index.php/TLS1.3
    136         for further important information). The TLSv1.3 implementation includes:
    137           o Fully compliant implementation of RFC8446 (TLSv1.3) on by default
    138           o Early data (0-RTT)
    139           o Post-handshake authentication and key update
    140           o Middlebox Compatibility Mode
    141           o TLSv1.3 PSKs
    142           o Support for all five RFC8446 ciphersuites
    143           o RSA-PSS signature algorithms (backported to TLSv1.2)
    144           o Configurable session ticket support
    145           o Stateless server support
    146           o Rewrite of the packet construction code for "safer" packet handling
    147           o Rewrite of the extension handling code
    148       o Complete rewrite of the OpenSSL random number generator to introduce the
    149         following capabilities
    150           o The default RAND method now utilizes an AES-CTR DRBG according to
    151             NIST standard SP 800-90Ar1.
    152           o Support for multiple DRBG instances with seed chaining.
    153           o There is a public and private DRBG instance.
    154           o The DRBG instances are fork-safe.
    155           o Keep all global DRBG instances on the secure heap if it is enabled.
    156           o The public and private DRBG instance are per thread for lock free
    157             operation
    158       o Support for various new cryptographic algorithms including:
    159           o SHA3
    160           o SHA512/224 and SHA512/256
    161           o EdDSA (both Ed25519 and Ed448) including X509 and TLS support
    162           o X448 (adding to the existing X25519 support in 1.1.0)
    163           o Multi-prime RSA
    164           o SM2
    165           o SM3
    166           o SM4
    167           o SipHash
    168           o ARIA (including TLS support)
    169       o Significant Side-Channel attack security improvements
    170       o Add a new ClientHello callback to provide the ability to adjust the SSL
    171         object at an early stage.
    172       o Add 'Maximum Fragment Length' TLS extension negotiation and support
    173       o A new STORE module, which implements a uniform and URI based reader of
    174         stores that can contain keys, certificates, CRLs and numerous other
    175         objects.
    176       o Move the display of configuration data to configdata.pm.
    177       o Allow GNU style "make variables" to be used with Configure.
    178       o Claim the namespaces OSSL and OPENSSL, represented as symbol prefixes
    179       o Rewrite of devcrypto engine
    180 
    181   Major changes between OpenSSL 1.1.0h and OpenSSL 1.1.0i [under development]
    182 
    183       o Client DoS due to large DH parameter (CVE-2018-0732)
    184       o Cache timing vulnerability in RSA Key Generation (CVE-2018-0737)
    185 
    186   Major changes between OpenSSL 1.1.0g and OpenSSL 1.1.0h [under development]
    187 
    188       o Constructed ASN.1 types with a recursive definition could exceed the
    189         stack (CVE-2018-0739)
    190       o Incorrect CRYPTO_memcmp on HP-UX PA-RISC (CVE-2018-0733)
    191       o rsaz_1024_mul_avx2 overflow bug on x86_64 (CVE-2017-3738)
    192 
    193   Major changes between OpenSSL 1.1.0f and OpenSSL 1.1.0g [2 Nov 2017]
    194 
    195       o bn_sqrx8x_internal carry bug on x86_64 (CVE-2017-3736)
    196       o Malformed X.509 IPAddressFamily could cause OOB read (CVE-2017-3735)
    197 
    198   Major changes between OpenSSL 1.1.0e and OpenSSL 1.1.0f [25 May 2017]
    199 
    200       o config now recognises 64-bit mingw and chooses mingw64 instead of mingw
    201 
    202   Major changes between OpenSSL 1.1.0d and OpenSSL 1.1.0e [16 Feb 2017]
    203 
    204       o Encrypt-Then-Mac renegotiation crash (CVE-2017-3733)
    205 
    206   Major changes between OpenSSL 1.1.0c and OpenSSL 1.1.0d [26 Jan 2017]
    207 
    208       o Truncated packet could crash via OOB read (CVE-2017-3731)
    209       o Bad (EC)DHE parameters cause a client crash (CVE-2017-3730)
    210       o BN_mod_exp may produce incorrect results on x86_64 (CVE-2017-3732)
    211 
    212   Major changes between OpenSSL 1.1.0b and OpenSSL 1.1.0c [10 Nov 2016]
    213 
    214       o ChaCha20/Poly1305 heap-buffer-overflow (CVE-2016-7054)
    215       o CMS Null dereference (CVE-2016-7053)
    216       o Montgomery multiplication may produce incorrect results (CVE-2016-7055)
    217 
    218   Major changes between OpenSSL 1.1.0a and OpenSSL 1.1.0b [26 Sep 2016]
    219 
    220       o Fix Use After Free for large message sizes (CVE-2016-6309)
    221 
    222   Major changes between OpenSSL 1.1.0 and OpenSSL 1.1.0a [22 Sep 2016]
    223 
    224       o OCSP Status Request extension unbounded memory growth (CVE-2016-6304)
    225       o SSL_peek() hang on empty record (CVE-2016-6305)
    226       o Excessive allocation of memory in tls_get_message_header()
    227        (CVE-2016-6307)
    228       o Excessive allocation of memory in dtls1_preprocess_fragment()
    229        (CVE-2016-6308)
    230 
    231   Major changes between OpenSSL 1.0.2h and OpenSSL 1.1.0 [25 Aug 2016]
    232 
    233       o Copyright text was shrunk to a boilerplate that points to the license
    234       o "shared" builds are now the default when possible
    235       o Added support for "pipelining"
    236       o Added the AFALG engine
    237       o New threading API implemented
    238       o Support for ChaCha20 and Poly1305 added to libcrypto and libssl
    239       o Support for extended master secret
    240       o CCM ciphersuites
    241       o Reworked test suite, now based on perl, Test::Harness and Test::More
    242       o *Most* libcrypto and libssl public structures were made opaque,
    243         including:
    244         BIGNUM and associated types, EC_KEY and EC_KEY_METHOD,
    245         DH and DH_METHOD, DSA and DSA_METHOD, RSA and RSA_METHOD,
    246         BIO and BIO_METHOD, EVP_MD_CTX, EVP_MD, EVP_CIPHER_CTX,
    247         EVP_CIPHER, EVP_PKEY and associated types, HMAC_CTX,
    248         X509, X509_CRL, X509_OBJECT, X509_STORE_CTX, X509_STORE,
    249         X509_LOOKUP, X509_LOOKUP_METHOD
    250       o libssl internal structures made opaque
    251       o SSLv2 support removed
    252       o Kerberos ciphersuite support removed
    253       o RC4 removed from DEFAULT ciphersuites in libssl
    254       o 40 and 56 bit cipher support removed from libssl
    255       o All public header files moved to include/openssl, no more symlinking
    256       o SSL/TLS state machine, version negotiation and record layer rewritten
    257       o EC revision: now operations use new EC_KEY_METHOD.
    258       o Support for OCB mode added to libcrypto
    259       o Support for asynchronous crypto operations added to libcrypto and libssl
    260       o Deprecated interfaces can now be disabled at build time either
    261         relative to the latest release via the "no-deprecated" Configure
    262         argument, or via the "--api=1.1.0|1.0.0|0.9.8" option.
    263       o Application software can be compiled with -DOPENSSL_API_COMPAT=version
    264         to ensure that features deprecated in that version are not exposed.
    265       o Support for RFC6698/RFC7671 DANE TLSA peer authentication
    266       o Change of Configure to use --prefix as the main installation
    267         directory location rather than --openssldir.  The latter becomes
    268         the directory for certs, private key and openssl.cnf exclusively.
    269       o Reworked BIO networking library, with full support for IPv6.
    270       o New "unified" build system
    271       o New security levels
    272       o Support for scrypt algorithm
    273       o Support for X25519
    274       o Extended SSL_CONF support using configuration files
    275       o KDF algorithm support. Implement TLS PRF as a KDF.
    276       o Support for Certificate Transparency
    277       o HKDF support.
    278 
    279   Major changes between OpenSSL 1.0.2g and OpenSSL 1.0.2h [3 May 2016]
    280 
    281       o Prevent padding oracle in AES-NI CBC MAC check (CVE-2016-2107)
    282       o Fix EVP_EncodeUpdate overflow (CVE-2016-2105)
    283       o Fix EVP_EncryptUpdate overflow (CVE-2016-2106)
    284       o Prevent ASN.1 BIO excessive memory allocation (CVE-2016-2109)
    285       o EBCDIC overread (CVE-2016-2176)
    286       o Modify behavior of ALPN to invoke callback after SNI/servername
    287         callback, such that updates to the SSL_CTX affect ALPN.
    288       o Remove LOW from the DEFAULT cipher list.  This removes singles DES from
    289         the default.
    290       o Only remove the SSLv2 methods with the no-ssl2-method option.
    291 
    292   Major changes between OpenSSL 1.0.2f and OpenSSL 1.0.2g [1 Mar 2016]
    293 
    294       o Disable weak ciphers in SSLv3 and up in default builds of OpenSSL.
    295       o Disable SSLv2 default build, default negotiation and weak ciphers
    296         (CVE-2016-0800)
    297       o Fix a double-free in DSA code (CVE-2016-0705)
    298       o Disable SRP fake user seed to address a server memory leak
    299         (CVE-2016-0798)
    300       o Fix BN_hex2bn/BN_dec2bn NULL pointer deref/heap corruption
    301         (CVE-2016-0797)
    302       o Fix memory issues in BIO_*printf functions (CVE-2016-0799)
    303       o Fix side channel attack on modular exponentiation (CVE-2016-0702)
    304 
    305   Major changes between OpenSSL 1.0.2e and OpenSSL 1.0.2f [28 Jan 2016]
    306 
    307       o DH small subgroups (CVE-2016-0701)
    308       o SSLv2 doesn't block disabled ciphers (CVE-2015-3197)
    309 
    310   Major changes between OpenSSL 1.0.2d and OpenSSL 1.0.2e [3 Dec 2015]
    311 
    312       o BN_mod_exp may produce incorrect results on x86_64 (CVE-2015-3193)
    313       o Certificate verify crash with missing PSS parameter (CVE-2015-3194)
    314       o X509_ATTRIBUTE memory leak (CVE-2015-3195)
    315       o Rewrite EVP_DecodeUpdate (base64 decoding) to fix several bugs
    316       o In DSA_generate_parameters_ex, if the provided seed is too short,
    317         return an error
    318 
    319   Major changes between OpenSSL 1.0.2c and OpenSSL 1.0.2d [9 Jul 2015]
    320 
    321       o Alternate chains certificate forgery (CVE-2015-1793)
    322       o Race condition handling PSK identify hint (CVE-2015-3196)
    323 
    324   Major changes between OpenSSL 1.0.2b and OpenSSL 1.0.2c [12 Jun 2015]
    325 
    326       o Fix HMAC ABI incompatibility
    327 
    328   Major changes between OpenSSL 1.0.2a and OpenSSL 1.0.2b [11 Jun 2015]
    329 
    330       o Malformed ECParameters causes infinite loop (CVE-2015-1788)
    331       o Exploitable out-of-bounds read in X509_cmp_time (CVE-2015-1789)
    332       o PKCS7 crash with missing EnvelopedContent (CVE-2015-1790)
    333       o CMS verify infinite loop with unknown hash function (CVE-2015-1792)
    334       o Race condition handling NewSessionTicket (CVE-2015-1791)
    335 
    336   Major changes between OpenSSL 1.0.2 and OpenSSL 1.0.2a [19 Mar 2015]
    337 
    338       o OpenSSL 1.0.2 ClientHello sigalgs DoS fix (CVE-2015-0291)
    339       o Multiblock corrupted pointer fix (CVE-2015-0290)
    340       o Segmentation fault in DTLSv1_listen fix (CVE-2015-0207)
    341       o Segmentation fault in ASN1_TYPE_cmp fix (CVE-2015-0286)
    342       o Segmentation fault for invalid PSS parameters fix (CVE-2015-0208)
    343       o ASN.1 structure reuse memory corruption fix (CVE-2015-0287)
    344       o PKCS7 NULL pointer dereferences fix (CVE-2015-0289)
    345       o DoS via reachable assert in SSLv2 servers fix (CVE-2015-0293)
    346       o Empty CKE with client auth and DHE fix (CVE-2015-1787)
    347       o Handshake with unseeded PRNG fix (CVE-2015-0285)
    348       o Use After Free following d2i_ECPrivatekey error fix (CVE-2015-0209)
    349       o X509_to_X509_REQ NULL pointer deref fix (CVE-2015-0288)
    350       o Removed the export ciphers from the DEFAULT ciphers
    351 
    352   Major changes between OpenSSL 1.0.1l and OpenSSL 1.0.2 [22 Jan 2015]:
    353 
    354       o Suite B support for TLS 1.2 and DTLS 1.2
    355       o Support for DTLS 1.2
    356       o TLS automatic EC curve selection.
    357       o API to set TLS supported signature algorithms and curves
    358       o SSL_CONF configuration API.
    359       o TLS Brainpool support.
    360       o ALPN support.
    361       o CMS support for RSA-PSS, RSA-OAEP, ECDH and X9.42 DH.
    362 
    363   Major changes between OpenSSL 1.0.1k and OpenSSL 1.0.1l [15 Jan 2015]
    364 
    365       o Build fixes for the Windows and OpenVMS platforms
    366 
    367   Major changes between OpenSSL 1.0.1j and OpenSSL 1.0.1k [8 Jan 2015]
    368 
    369       o Fix for CVE-2014-3571
    370       o Fix for CVE-2015-0206
    371       o Fix for CVE-2014-3569
    372       o Fix for CVE-2014-3572
    373       o Fix for CVE-2015-0204
    374       o Fix for CVE-2015-0205
    375       o Fix for CVE-2014-8275
    376       o Fix for CVE-2014-3570
    377 
    378   Major changes between OpenSSL 1.0.1i and OpenSSL 1.0.1j [15 Oct 2014]
    379 
    380       o Fix for CVE-2014-3513
    381       o Fix for CVE-2014-3567
    382       o Mitigation for CVE-2014-3566 (SSL protocol vulnerability)
    383       o Fix for CVE-2014-3568
    384 
    385   Major changes between OpenSSL 1.0.1h and OpenSSL 1.0.1i [6 Aug 2014]
    386 
    387       o Fix for CVE-2014-3512
    388       o Fix for CVE-2014-3511
    389       o Fix for CVE-2014-3510
    390       o Fix for CVE-2014-3507
    391       o Fix for CVE-2014-3506
    392       o Fix for CVE-2014-3505
    393       o Fix for CVE-2014-3509
    394       o Fix for CVE-2014-5139
    395       o Fix for CVE-2014-3508
    396 
    397   Major changes between OpenSSL 1.0.1g and OpenSSL 1.0.1h [5 Jun 2014]
    398 
    399       o Fix for CVE-2014-0224
    400       o Fix for CVE-2014-0221
    401       o Fix for CVE-2014-0198
    402       o Fix for CVE-2014-0195
    403       o Fix for CVE-2014-3470
    404       o Fix for CVE-2010-5298
    405 
    406   Major changes between OpenSSL 1.0.1f and OpenSSL 1.0.1g [7 Apr 2014]
    407 
    408       o Fix for CVE-2014-0160
    409       o Add TLS padding extension workaround for broken servers.
    410       o Fix for CVE-2014-0076
    411 
    412   Major changes between OpenSSL 1.0.1e and OpenSSL 1.0.1f [6 Jan 2014]
    413 
    414       o Don't include gmt_unix_time in TLS server and client random values
    415       o Fix for TLS record tampering bug CVE-2013-4353
    416       o Fix for TLS version checking bug CVE-2013-6449
    417       o Fix for DTLS retransmission bug CVE-2013-6450
    418 
    419   Major changes between OpenSSL 1.0.1d and OpenSSL 1.0.1e [11 Feb 2013]:
    420 
    421       o Corrected fix for CVE-2013-0169
    422 
    423   Major changes between OpenSSL 1.0.1c and OpenSSL 1.0.1d [4 Feb 2013]:
    424 
    425       o Fix renegotiation in TLS 1.1, 1.2 by using the correct TLS version.
    426       o Include the fips configuration module.
    427       o Fix OCSP bad key DoS attack CVE-2013-0166
    428       o Fix for SSL/TLS/DTLS CBC plaintext recovery attack CVE-2013-0169
    429       o Fix for TLS AESNI record handling flaw CVE-2012-2686
    430 
    431   Major changes between OpenSSL 1.0.1b and OpenSSL 1.0.1c [10 May 2012]:
    432 
    433       o Fix TLS/DTLS record length checking bug CVE-2012-2333
    434       o Don't attempt to use non-FIPS composite ciphers in FIPS mode.
    435 
    436   Major changes between OpenSSL 1.0.1a and OpenSSL 1.0.1b [26 Apr 2012]:
    437 
    438       o Fix compilation error on non-x86 platforms.
    439       o Make FIPS capable OpenSSL ciphers work in non-FIPS mode.
    440       o Fix SSL_OP_NO_TLSv1_1 clash with SSL_OP_ALL in OpenSSL 1.0.0
    441 
    442   Major changes between OpenSSL 1.0.1 and OpenSSL 1.0.1a [19 Apr 2012]:
    443 
    444       o Fix for ASN1 overflow bug CVE-2012-2110
    445       o Workarounds for some servers that hang on long client hellos.
    446       o Fix SEGV in AES code.
    447 
    448   Major changes between OpenSSL 1.0.0h and OpenSSL 1.0.1 [14 Mar 2012]:
    449 
    450       o TLS/DTLS heartbeat support.
    451       o SCTP support.
    452       o RFC 5705 TLS key material exporter.
    453       o RFC 5764 DTLS-SRTP negotiation.
    454       o Next Protocol Negotiation.
    455       o PSS signatures in certificates, requests and CRLs.
    456       o Support for password based recipient info for CMS.
    457       o Support TLS v1.2 and TLS v1.1.
    458       o Preliminary FIPS capability for unvalidated 2.0 FIPS module.
    459       o SRP support.
    460 
    461   Major changes between OpenSSL 1.0.0g and OpenSSL 1.0.0h [12 Mar 2012]:
    462 
    463       o Fix for CMS/PKCS#7 MMA CVE-2012-0884
    464       o Corrected fix for CVE-2011-4619
    465       o Various DTLS fixes.
    466 
    467   Major changes between OpenSSL 1.0.0f and OpenSSL 1.0.0g [18 Jan 2012]:
    468 
    469       o Fix for DTLS DoS issue CVE-2012-0050
    470 
    471   Major changes between OpenSSL 1.0.0e and OpenSSL 1.0.0f [4 Jan 2012]:
    472 
    473       o Fix for DTLS plaintext recovery attack CVE-2011-4108
    474       o Clear block padding bytes of SSL 3.0 records CVE-2011-4576
    475       o Only allow one SGC handshake restart for SSL/TLS CVE-2011-4619
    476       o Check parameters are not NULL in GOST ENGINE CVE-2012-0027
    477       o Check for malformed RFC3779 data CVE-2011-4577
    478 
    479   Major changes between OpenSSL 1.0.0d and OpenSSL 1.0.0e [6 Sep 2011]:
    480 
    481       o Fix for CRL vulnerability issue CVE-2011-3207
    482       o Fix for ECDH crashes CVE-2011-3210
    483       o Protection against EC timing attacks.
    484       o Support ECDH ciphersuites for certificates using SHA2 algorithms.
    485       o Various DTLS fixes.
    486 
    487   Major changes between OpenSSL 1.0.0c and OpenSSL 1.0.0d [8 Feb 2011]:
    488 
    489       o Fix for security issue CVE-2011-0014
    490 
    491   Major changes between OpenSSL 1.0.0b and OpenSSL 1.0.0c [2 Dec 2010]:
    492 
    493       o Fix for security issue CVE-2010-4180
    494       o Fix for CVE-2010-4252
    495       o Fix mishandling of absent EC point format extension.
    496       o Fix various platform compilation issues.
    497       o Corrected fix for security issue CVE-2010-3864.
    498 
    499   Major changes between OpenSSL 1.0.0a and OpenSSL 1.0.0b [16 Nov 2010]:
    500 
    501       o Fix for security issue CVE-2010-3864.
    502       o Fix for CVE-2010-2939
    503       o Fix WIN32 build system for GOST ENGINE.
    504 
    505   Major changes between OpenSSL 1.0.0 and OpenSSL 1.0.0a [1 Jun 2010]:
    506 
    507       o Fix for security issue CVE-2010-1633.
    508       o GOST MAC and CFB fixes.
    509 
    510   Major changes between OpenSSL 0.9.8n and OpenSSL 1.0.0 [29 Mar 2010]:
    511 
    512       o RFC3280 path validation: sufficient to process PKITS tests.
    513       o Integrated support for PVK files and keyblobs.
    514       o Change default private key format to PKCS#8.
    515       o CMS support: able to process all examples in RFC4134
    516       o Streaming ASN1 encode support for PKCS#7 and CMS.
    517       o Multiple signer and signer add support for PKCS#7 and CMS.
    518       o ASN1 printing support.
    519       o Whirlpool hash algorithm added.
    520       o RFC3161 time stamp support.
    521       o New generalised public key API supporting ENGINE based algorithms.
    522       o New generalised public key API utilities.
    523       o New ENGINE supporting GOST algorithms.
    524       o SSL/TLS GOST ciphersuite support.
    525       o PKCS#7 and CMS GOST support.
    526       o RFC4279 PSK ciphersuite support.
    527       o Supported points format extension for ECC ciphersuites.
    528       o ecdsa-with-SHA224/256/384/512 signature types.
    529       o dsa-with-SHA224 and dsa-with-SHA256 signature types.
    530       o Opaque PRF Input TLS extension support.
    531       o Updated time routines to avoid OS limitations.
    532 
    533   Major changes between OpenSSL 0.9.8m and OpenSSL 0.9.8n [24 Mar 2010]:
    534 
    535       o CFB cipher definition fixes.
    536       o Fix security issues CVE-2010-0740 and CVE-2010-0433.
    537 
    538   Major changes between OpenSSL 0.9.8l and OpenSSL 0.9.8m [25 Feb 2010]:
    539 
    540       o Cipher definition fixes.
    541       o Workaround for slow RAND_poll() on some WIN32 versions.
    542       o Remove MD2 from algorithm tables.
    543       o SPKAC handling fixes.
    544       o Support for RFC5746 TLS renegotiation extension.
    545       o Compression memory leak fixed.
    546       o Compression session resumption fixed.
    547       o Ticket and SNI coexistence fixes.
    548       o Many fixes to DTLS handling.
    549 
    550   Major changes between OpenSSL 0.9.8k and OpenSSL 0.9.8l [5 Nov 2009]:
    551 
    552       o Temporary work around for CVE-2009-3555: disable renegotiation.
    553 
    554   Major changes between OpenSSL 0.9.8j and OpenSSL 0.9.8k [25 Mar 2009]:
    555 
    556       o Fix various build issues.
    557       o Fix security issues (CVE-2009-0590, CVE-2009-0591, CVE-2009-0789)
    558 
    559   Major changes between OpenSSL 0.9.8i and OpenSSL 0.9.8j [7 Jan 2009]:
    560 
    561       o Fix security issue (CVE-2008-5077)
    562       o Merge FIPS 140-2 branch code.
    563 
    564   Major changes between OpenSSL 0.9.8g and OpenSSL 0.9.8h [28 May 2008]:
    565 
    566       o CryptoAPI ENGINE support.
    567       o Various precautionary measures.
    568       o Fix for bugs affecting certificate request creation.
    569       o Support for local machine keyset attribute in PKCS#12 files.
    570 
    571   Major changes between OpenSSL 0.9.8f and OpenSSL 0.9.8g [19 Oct 2007]:
    572 
    573       o Backport of CMS functionality to 0.9.8.
    574       o Fixes for bugs introduced with 0.9.8f.
    575 
    576   Major changes between OpenSSL 0.9.8e and OpenSSL 0.9.8f [11 Oct 2007]:
    577 
    578       o Add gcc 4.2 support.
    579       o Add support for AES and SSE2 assembly language optimization
    580         for VC++ build.
    581       o Support for RFC4507bis and server name extensions if explicitly
    582         selected at compile time.
    583       o DTLS improvements.
    584       o RFC4507bis support.
    585       o TLS Extensions support.
    586 
    587   Major changes between OpenSSL 0.9.8d and OpenSSL 0.9.8e [23 Feb 2007]:
    588 
    589       o Various ciphersuite selection fixes.
    590       o RFC3779 support.
    591 
    592   Major changes between OpenSSL 0.9.8c and OpenSSL 0.9.8d [28 Sep 2006]:
    593 
    594       o Introduce limits to prevent malicious key DoS  (CVE-2006-2940)
    595       o Fix security issues (CVE-2006-2937, CVE-2006-3737, CVE-2006-4343)
    596       o Changes to ciphersuite selection algorithm
    597 
    598   Major changes between OpenSSL 0.9.8b and OpenSSL 0.9.8c [5 Sep 2006]:
    599 
    600       o Fix Daniel Bleichenbacher forged signature attack, CVE-2006-4339
    601       o New cipher Camellia
    602 
    603   Major changes between OpenSSL 0.9.8a and OpenSSL 0.9.8b [4 May 2006]:
    604 
    605       o Cipher string fixes.
    606       o Fixes for VC++ 2005.
    607       o Updated ECC cipher suite support.
    608       o New functions EVP_CIPHER_CTX_new() and EVP_CIPHER_CTX_free().
    609       o Zlib compression usage fixes.
    610       o Built in dynamic engine compilation support on Win32.
    611       o Fixes auto dynamic engine loading in Win32.
    612 
    613   Major changes between OpenSSL 0.9.8 and OpenSSL 0.9.8a [11 Oct 2005]:
    614 
    615       o Fix potential SSL 2.0 rollback, CVE-2005-2969
    616       o Extended Windows CE support
    617 
    618   Major changes between OpenSSL 0.9.7g and OpenSSL 0.9.8 [5 Jul 2005]:
    619 
    620       o Major work on the BIGNUM library for higher efficiency and to
    621         make operations more streamlined and less contradictory.  This
    622         is the result of a major audit of the BIGNUM library.
    623       o Addition of BIGNUM functions for fields GF(2^m) and NIST
    624         curves, to support the Elliptic Crypto functions.
    625       o Major work on Elliptic Crypto; ECDH and ECDSA added, including
    626         the use through EVP, X509 and ENGINE.
    627       o New ASN.1 mini-compiler that's usable through the OpenSSL
    628         configuration file.
    629       o Added support for ASN.1 indefinite length constructed encoding.
    630       o New PKCS#12 'medium level' API to manipulate PKCS#12 files.
    631       o Complete rework of shared library construction and linking
    632         programs with shared or static libraries, through a separate
    633         Makefile.shared.
    634       o Rework of the passing of parameters from one Makefile to another.
    635       o Changed ENGINE framework to load dynamic engine modules
    636         automatically from specifically given directories.
    637       o New structure and ASN.1 functions for CertificatePair.
    638       o Changed the ZLIB compression method to be stateful.
    639       o Changed the key-generation and primality testing "progress"
    640         mechanism to take a structure that contains the ticker
    641         function and an argument.
    642       o New engine module: GMP (performs private key exponentiation).
    643       o New engine module: VIA PadLOck ACE extension in VIA C3
    644         Nehemiah processors.
    645       o Added support for IPv6 addresses in certificate extensions.
    646         See RFC 1884, section 2.2.
    647       o Added support for certificate policy mappings, policy
    648         constraints and name constraints.
    649       o Added support for multi-valued AVAs in the OpenSSL
    650         configuration file.
    651       o Added support for multiple certificates with the same subject
    652         in the 'openssl ca' index file.
    653       o Make it possible to create self-signed certificates using
    654         'openssl ca -selfsign'.
    655       o Make it possible to generate a serial number file with
    656         'openssl ca -create_serial'.
    657       o New binary search functions with extended functionality.
    658       o New BUF functions.
    659       o New STORE structure and library to provide an interface to all
    660         sorts of data repositories.  Supports storage of public and
    661         private keys, certificates, CRLs, numbers and arbitrary blobs.
    662         This library is unfortunately unfinished and unused within
    663         OpenSSL.
    664       o New control functions for the error stack.
    665       o Changed the PKCS#7 library to support one-pass S/MIME
    666         processing.
    667       o Added the possibility to compile without old deprecated
    668         functionality with the OPENSSL_NO_DEPRECATED macro or the
    669         'no-deprecated' argument to the config and Configure scripts.
    670       o Constification of all ASN.1 conversion functions, and other
    671         affected functions.
    672       o Improved platform support for PowerPC.
    673       o New FIPS 180-2 algorithms (SHA-224, -256, -384 and -512).
    674       o New X509_VERIFY_PARAM structure to support parameterisation
    675         of X.509 path validation.
    676       o Major overhaul of RC4 performance on Intel P4, IA-64 and
    677         AMD64.
    678       o Changed the Configure script to have some algorithms disabled
    679         by default.  Those can be explicitly enabled with the new
    680         argument form 'enable-xxx'.
    681       o Change the default digest in 'openssl' commands from MD5 to
    682         SHA-1.
    683       o Added support for DTLS.
    684       o New BIGNUM blinding.
    685       o Added support for the RSA-PSS encryption scheme
    686       o Added support for the RSA X.931 padding.
    687       o Added support for BSD sockets on NetWare.
    688       o Added support for files larger than 2GB.
    689       o Added initial support for Win64.
    690       o Added alternate pkg-config files.
    691 
    692   Major changes between OpenSSL 0.9.7l and OpenSSL 0.9.7m [23 Feb 2007]:
    693 
    694       o FIPS 1.1.1 module linking.
    695       o Various ciphersuite selection fixes.
    696 
    697   Major changes between OpenSSL 0.9.7k and OpenSSL 0.9.7l [28 Sep 2006]:
    698 
    699       o Introduce limits to prevent malicious key DoS  (CVE-2006-2940)
    700       o Fix security issues (CVE-2006-2937, CVE-2006-3737, CVE-2006-4343)
    701 
    702   Major changes between OpenSSL 0.9.7j and OpenSSL 0.9.7k [5 Sep 2006]:
    703 
    704       o Fix Daniel Bleichenbacher forged signature attack, CVE-2006-4339
    705 
    706   Major changes between OpenSSL 0.9.7i and OpenSSL 0.9.7j [4 May 2006]:
    707 
    708       o Visual C++ 2005 fixes.
    709       o Update Windows build system for FIPS.
    710 
    711   Major changes between OpenSSL 0.9.7h and OpenSSL 0.9.7i [14 Oct 2005]:
    712 
    713       o Give EVP_MAX_MD_SIZE its old value, except for a FIPS build.
    714 
    715   Major changes between OpenSSL 0.9.7g and OpenSSL 0.9.7h [11 Oct 2005]:
    716 
    717       o Fix SSL 2.0 Rollback, CVE-2005-2969
    718       o Allow use of fixed-length exponent on DSA signing
    719       o Default fixed-window RSA, DSA, DH private-key operations
    720 
    721   Major changes between OpenSSL 0.9.7f and OpenSSL 0.9.7g [11 Apr 2005]:
    722 
    723       o More compilation issues fixed.
    724       o Adaptation to more modern Kerberos API.
    725       o Enhanced or corrected configuration for Solaris64, Mingw and Cygwin.
    726       o Enhanced x86_64 assembler BIGNUM module.
    727       o More constification.
    728       o Added processing of proxy certificates (RFC 3820).
    729 
    730   Major changes between OpenSSL 0.9.7e and OpenSSL 0.9.7f [22 Mar 2005]:
    731 
    732       o Several compilation issues fixed.
    733       o Many memory allocation failure checks added.
    734       o Improved comparison of X509 Name type.
    735       o Mandatory basic checks on certificates.
    736       o Performance improvements.
    737 
    738   Major changes between OpenSSL 0.9.7d and OpenSSL 0.9.7e [25 Oct 2004]:
    739 
    740       o Fix race condition in CRL checking code.
    741       o Fixes to PKCS#7 (S/MIME) code.
    742 
    743   Major changes between OpenSSL 0.9.7c and OpenSSL 0.9.7d [17 Mar 2004]:
    744 
    745       o Security: Fix Kerberos ciphersuite SSL/TLS handshaking bug
    746       o Security: Fix null-pointer assignment in do_change_cipher_spec()
    747       o Allow multiple active certificates with same subject in CA index
    748       o Multiple X509 verification fixes
    749       o Speed up HMAC and other operations
    750 
    751   Major changes between OpenSSL 0.9.7b and OpenSSL 0.9.7c [30 Sep 2003]:
    752 
    753       o Security: fix various ASN1 parsing bugs.
    754       o New -ignore_err option to OCSP utility.
    755       o Various interop and bug fixes in S/MIME code.
    756       o SSL/TLS protocol fix for unrequested client certificates.
    757 
    758   Major changes between OpenSSL 0.9.7a and OpenSSL 0.9.7b [10 Apr 2003]:
    759 
    760       o Security: counter the Klima-Pokorny-Rosa extension of
    761         Bleichbacher's attack
    762       o Security: make RSA blinding default.
    763       o Configuration: Irix fixes, AIX fixes, better mingw support.
    764       o Support for new platforms: linux-ia64-ecc.
    765       o Build: shared library support fixes.
    766       o ASN.1: treat domainComponent correctly.
    767       o Documentation: fixes and additions.
    768 
    769   Major changes between OpenSSL 0.9.7 and OpenSSL 0.9.7a [19 Feb 2003]:
    770 
    771       o Security: Important security related bugfixes.
    772       o Enhanced compatibility with MIT Kerberos.
    773       o Can be built without the ENGINE framework.
    774       o IA32 assembler enhancements.
    775       o Support for new platforms: FreeBSD/IA64 and FreeBSD/Sparc64.
    776       o Configuration: the no-err option now works properly.
    777       o SSL/TLS: now handles manual certificate chain building.
    778       o SSL/TLS: certain session ID malfunctions corrected.
    779 
    780   Major changes between OpenSSL 0.9.6 and OpenSSL 0.9.7 [30 Dec 2002]:
    781 
    782       o New library section OCSP.
    783       o Complete rewrite of ASN1 code.
    784       o CRL checking in verify code and openssl utility.
    785       o Extension copying in 'ca' utility.
    786       o Flexible display options in 'ca' utility.
    787       o Provisional support for international characters with UTF8.
    788       o Support for external crypto devices ('engine') is no longer
    789         a separate distribution.
    790       o New elliptic curve library section.
    791       o New AES (Rijndael) library section.
    792       o Support for new platforms: Windows CE, Tandem OSS, A/UX, AIX 64-bit,
    793         Linux x86_64, Linux 64-bit on Sparc v9
    794       o Extended support for some platforms: VxWorks
    795       o Enhanced support for shared libraries.
    796       o Now only builds PIC code when shared library support is requested.
    797       o Support for pkg-config.
    798       o Lots of new manuals.
    799       o Makes symbolic links to or copies of manuals to cover all described
    800         functions.
    801       o Change DES API to clean up the namespace (some applications link also
    802         against libdes providing similar functions having the same name).
    803         Provide macros for backward compatibility (will be removed in the
    804         future).
    805       o Unify handling of cryptographic algorithms (software and engine)
    806         to be available via EVP routines for asymmetric and symmetric ciphers.
    807       o NCONF: new configuration handling routines.
    808       o Change API to use more 'const' modifiers to improve error checking
    809         and help optimizers.
    810       o Finally remove references to RSAref.
    811       o Reworked parts of the BIGNUM code.
    812       o Support for new engines: Broadcom ubsec, Accelerated Encryption
    813         Processing, IBM 4758.
    814       o A few new engines added in the demos area.
    815       o Extended and corrected OID (object identifier) table.
    816       o PRNG: query at more locations for a random device, automatic query for
    817         EGD style random sources at several locations.
    818       o SSL/TLS: allow optional cipher choice according to server's preference.
    819       o SSL/TLS: allow server to explicitly set new session ids.
    820       o SSL/TLS: support Kerberos cipher suites (RFC2712).
    821         Only supports MIT Kerberos for now.
    822       o SSL/TLS: allow more precise control of renegotiations and sessions.
    823       o SSL/TLS: add callback to retrieve SSL/TLS messages.
    824       o SSL/TLS: support AES cipher suites (RFC3268).
    825 
    826   Major changes between OpenSSL 0.9.6j and OpenSSL 0.9.6k [30 Sep 2003]:
    827 
    828       o Security: fix various ASN1 parsing bugs.
    829       o SSL/TLS protocol fix for unrequested client certificates.
    830 
    831   Major changes between OpenSSL 0.9.6i and OpenSSL 0.9.6j [10 Apr 2003]:
    832 
    833       o Security: counter the Klima-Pokorny-Rosa extension of
    834         Bleichbacher's attack
    835       o Security: make RSA blinding default.
    836       o Build: shared library support fixes.
    837 
    838   Major changes between OpenSSL 0.9.6h and OpenSSL 0.9.6i [19 Feb 2003]:
    839 
    840       o Important security related bugfixes.
    841 
    842   Major changes between OpenSSL 0.9.6g and OpenSSL 0.9.6h [5 Dec 2002]:
    843 
    844       o New configuration targets for Tandem OSS and A/UX.
    845       o New OIDs for Microsoft attributes.
    846       o Better handling of SSL session caching.
    847       o Better comparison of distinguished names.
    848       o Better handling of shared libraries in a mixed GNU/non-GNU environment.
    849       o Support assembler code with Borland C.
    850       o Fixes for length problems.
    851       o Fixes for uninitialised variables.
    852       o Fixes for memory leaks, some unusual crashes and some race conditions.
    853       o Fixes for smaller building problems.
    854       o Updates of manuals, FAQ and other instructive documents.
    855 
    856   Major changes between OpenSSL 0.9.6f and OpenSSL 0.9.6g [9 Aug 2002]:
    857 
    858       o Important building fixes on Unix.
    859 
    860   Major changes between OpenSSL 0.9.6e and OpenSSL 0.9.6f [8 Aug 2002]:
    861 
    862       o Various important bugfixes.
    863 
    864   Major changes between OpenSSL 0.9.6d and OpenSSL 0.9.6e [30 Jul 2002]:
    865 
    866       o Important security related bugfixes.
    867       o Various SSL/TLS library bugfixes.
    868 
    869   Major changes between OpenSSL 0.9.6c and OpenSSL 0.9.6d [9 May 2002]:
    870 
    871       o Various SSL/TLS library bugfixes.
    872       o Fix DH parameter generation for 'non-standard' generators.
    873 
    874   Major changes between OpenSSL 0.9.6b and OpenSSL 0.9.6c [21 Dec 2001]:
    875 
    876       o Various SSL/TLS library bugfixes.
    877       o BIGNUM library fixes.
    878       o RSA OAEP and random number generation fixes.
    879       o Object identifiers corrected and added.
    880       o Add assembler BN routines for IA64.
    881       o Add support for OS/390 Unix, UnixWare with gcc, OpenUNIX 8,
    882         MIPS Linux; shared library support for Irix, HP-UX.
    883       o Add crypto accelerator support for AEP, Baltimore SureWare,
    884         Broadcom and Cryptographic Appliance's keyserver
    885         [in 0.9.6c-engine release].
    886 
    887   Major changes between OpenSSL 0.9.6a and OpenSSL 0.9.6b [9 Jul 2001]:
    888 
    889       o Security fix: PRNG improvements.
    890       o Security fix: RSA OAEP check.
    891       o Security fix: Reinsert and fix countermeasure to Bleichbacher's
    892         attack.
    893       o MIPS bug fix in BIGNUM.
    894       o Bug fix in "openssl enc".
    895       o Bug fix in X.509 printing routine.
    896       o Bug fix in DSA verification routine and DSA S/MIME verification.
    897       o Bug fix to make PRNG thread-safe.
    898       o Bug fix in RAND_file_name().
    899       o Bug fix in compatibility mode trust settings.
    900       o Bug fix in blowfish EVP.
    901       o Increase default size for BIO buffering filter.
    902       o Compatibility fixes in some scripts.
    903 
    904   Major changes between OpenSSL 0.9.6 and OpenSSL 0.9.6a [5 Apr 2001]:
    905 
    906       o Security fix: change behavior of OpenSSL to avoid using
    907         environment variables when running as root.
    908       o Security fix: check the result of RSA-CRT to reduce the
    909         possibility of deducing the private key from an incorrectly
    910         calculated signature.
    911       o Security fix: prevent Bleichenbacher's DSA attack.
    912       o Security fix: Zero the premaster secret after deriving the
    913         master secret in DH ciphersuites.
    914       o Reimplement SSL_peek(), which had various problems.
    915       o Compatibility fix: the function des_encrypt() renamed to
    916         des_encrypt1() to avoid clashes with some Unixen libc.
    917       o Bug fixes for Win32, HP/UX and Irix.
    918       o Bug fixes in BIGNUM, SSL, PKCS#7, PKCS#12, X.509, CONF and
    919         memory checking routines.
    920       o Bug fixes for RSA operations in threaded environments.
    921       o Bug fixes in misc. openssl applications.
    922       o Remove a few potential memory leaks.
    923       o Add tighter checks of BIGNUM routines.
    924       o Shared library support has been reworked for generality.
    925       o More documentation.
    926       o New function BN_rand_range().
    927       o Add "-rand" option to openssl s_client and s_server.
    928 
    929   Major changes between OpenSSL 0.9.5a and OpenSSL 0.9.6 [10 Oct 2000]:
    930 
    931       o Some documentation for BIO and SSL libraries.
    932       o Enhanced chain verification using key identifiers.
    933       o New sign and verify options to 'dgst' application.
    934       o Support for DER and PEM encoded messages in 'smime' application.
    935       o New 'rsautl' application, low level RSA utility.
    936       o MD4 now included.
    937       o Bugfix for SSL rollback padding check.
    938       o Support for external crypto devices [1].
    939       o Enhanced EVP interface.
    940 
    941     [1] The support for external crypto devices is currently a separate
    942         distribution.  See the file README.ENGINE.
    943 
    944   Major changes between OpenSSL 0.9.5 and OpenSSL 0.9.5a [1 Apr 2000]:
    945 
    946       o Bug fixes for Win32, SuSE Linux, NeXTSTEP and FreeBSD 2.2.8
    947       o Shared library support for HPUX and Solaris-gcc
    948       o Support of Linux/IA64
    949       o Assembler support for Mingw32
    950       o New 'rand' application
    951       o New way to check for existence of algorithms from scripts
    952 
    953   Major changes between OpenSSL 0.9.4 and OpenSSL 0.9.5 [25 May 2000]:
    954 
    955       o S/MIME support in new 'smime' command
    956       o Documentation for the OpenSSL command line application
    957       o Automation of 'req' application
    958       o Fixes to make s_client, s_server work under Windows
    959       o Support for multiple fieldnames in SPKACs
    960       o New SPKAC command line utility and associated library functions
    961       o Options to allow passwords to be obtained from various sources
    962       o New public key PEM format and options to handle it
    963       o Many other fixes and enhancements to command line utilities
    964       o Usable certificate chain verification
    965       o Certificate purpose checking
    966       o Certificate trust settings
    967       o Support of authority information access extension
    968       o Extensions in certificate requests
    969       o Simplified X509 name and attribute routines
    970       o Initial (incomplete) support for international character sets
    971       o New DH_METHOD, DSA_METHOD and enhanced RSA_METHOD
    972       o Read only memory BIOs and simplified creation function
    973       o TLS/SSL protocol bugfixes: Accept TLS 'client hello' in SSL 3.0
    974         record; allow fragmentation and interleaving of handshake and other
    975         data
    976       o TLS/SSL code now "tolerates" MS SGC
    977       o Work around for Netscape client certificate hang bug
    978       o RSA_NULL option that removes RSA patent code but keeps other
    979         RSA functionality
    980       o Memory leak detection now allows applications to add extra information
    981         via a per-thread stack
    982       o PRNG robustness improved
    983       o EGD support
    984       o BIGNUM library bug fixes
    985       o Faster DSA parameter generation
    986       o Enhanced support for Alpha Linux
    987       o Experimental MacOS support
    988 
    989   Major changes between OpenSSL 0.9.3 and OpenSSL 0.9.4 [9 Aug 1999]:
    990 
    991       o Transparent support for PKCS#8 format private keys: these are used
    992         by several software packages and are more secure than the standard
    993         form
    994       o PKCS#5 v2.0 implementation
    995       o Password callbacks have a new void * argument for application data
    996       o Avoid various memory leaks
    997       o New pipe-like BIO that allows using the SSL library when actual I/O
    998         must be handled by the application (BIO pair)
    999 
   1000   Major changes between OpenSSL 0.9.2b and OpenSSL 0.9.3 [24 May 1999]:
   1001       o Lots of enhancements and cleanups to the Configuration mechanism
   1002       o RSA OEAP related fixes
   1003       o Added `openssl ca -revoke' option for revoking a certificate
   1004       o Source cleanups: const correctness, type-safe stacks and ASN.1 SETs
   1005       o Source tree cleanups: removed lots of obsolete files
   1006       o Thawte SXNet, certificate policies and CRL distribution points
   1007         extension support
   1008       o Preliminary (experimental) S/MIME support
   1009       o Support for ASN.1 UTF8String and VisibleString
   1010       o Full integration of PKCS#12 code
   1011       o Sparc assembler bignum implementation, optimized hash functions
   1012       o Option to disable selected ciphers
   1013 
   1014   Major changes between OpenSSL 0.9.1c and OpenSSL 0.9.2b [22 Mar 1999]:
   1015       o Fixed a security hole related to session resumption
   1016       o Fixed RSA encryption routines for the p < q case
   1017       o "ALL" in cipher lists now means "everything except NULL ciphers"
   1018       o Support for Triple-DES CBCM cipher
   1019       o Support of Optimal Asymmetric Encryption Padding (OAEP) for RSA
   1020       o First support for new TLSv1 ciphers
   1021       o Added a few new BIOs (syslog BIO, reliable BIO)
   1022       o Extended support for DSA certificate/keys.
   1023       o Extended support for Certificate Signing Requests (CSR)
   1024       o Initial support for X.509v3 extensions
   1025       o Extended support for compression inside the SSL record layer
   1026       o Overhauled Win32 builds
   1027       o Cleanups and fixes to the Big Number (BN) library
   1028       o Support for ASN.1 GeneralizedTime
   1029       o Splitted ASN.1 SETs from SEQUENCEs
   1030       o ASN1 and PEM support for Netscape Certificate Sequences
   1031       o Overhauled Perl interface
   1032       o Lots of source tree cleanups.
   1033       o Lots of memory leak fixes.
   1034       o Lots of bug fixes.
   1035 
   1036   Major changes between SSLeay 0.9.0b and OpenSSL 0.9.1c [23 Dec 1998]:
   1037       o Integration of the popular NO_RSA/NO_DSA patches
   1038       o Initial support for compression inside the SSL record layer
   1039       o Added BIO proxy and filtering functionality
   1040       o Extended Big Number (BN) library
   1041       o Added RIPE MD160 message digest
   1042       o Added support for RC2/64bit cipher
   1043       o Extended ASN.1 parser routines
   1044       o Adjustments of the source tree for CVS
   1045       o Support for various new platforms
   1046