Home | History | Annotate | Line # | Download | only in dist
NEWS revision 1.1
      1 
      2   NEWS
      3   ====
      4 
      5   This file gives a brief overview of the major changes between each OpenSSL
      6   release. For more details please read the CHANGES file.
      7 
      8   Major changes between OpenSSL 1.0.2j and OpenSSL 1.0.2k [26 Jan 2017]
      9 
     10       o Truncated packet could crash via OOB read (CVE-2017-3731)
     11       o BN_mod_exp may produce incorrect results on x86_64 (CVE-2017-3732)
     12       o Montgomery multiplication may produce incorrect results (CVE-2016-7055)
     13 
     14   Major changes between OpenSSL 1.0.2i and OpenSSL 1.0.2j [26 Sep 2016]
     15 
     16       o Missing CRL sanity check (CVE-2016-7052)
     17 
     18   Major changes between OpenSSL 1.0.2h and OpenSSL 1.0.2i [22 Sep 2016]
     19 
     20       o OCSP Status Request extension unbounded memory growth (CVE-2016-6304)
     21       o SWEET32 Mitigation (CVE-2016-2183)
     22       o OOB write in MDC2_Update() (CVE-2016-6303)
     23       o Malformed SHA512 ticket DoS (CVE-2016-6302)
     24       o OOB write in BN_bn2dec() (CVE-2016-2182)
     25       o OOB read in TS_OBJ_print_bio() (CVE-2016-2180)
     26       o Pointer arithmetic undefined behaviour (CVE-2016-2177)
     27       o Constant time flag not preserved in DSA signing (CVE-2016-2178)
     28       o DTLS buffered message DoS (CVE-2016-2179)
     29       o DTLS replay protection DoS (CVE-2016-2181)
     30       o Certificate message OOB reads (CVE-2016-6306)
     31 
     32   Major changes between OpenSSL 1.0.2g and OpenSSL 1.0.2h [3 May 2016]
     33 
     34       o Prevent padding oracle in AES-NI CBC MAC check (CVE-2016-2107)
     35       o Fix EVP_EncodeUpdate overflow (CVE-2016-2105)
     36       o Fix EVP_EncryptUpdate overflow (CVE-2016-2106)
     37       o Prevent ASN.1 BIO excessive memory allocation (CVE-2016-2109)
     38       o EBCDIC overread (CVE-2016-2176)
     39       o Modify behavior of ALPN to invoke callback after SNI/servername
     40         callback, such that updates to the SSL_CTX affect ALPN.
     41       o Remove LOW from the DEFAULT cipher list.  This removes singles DES from
     42         the default.
     43       o Only remove the SSLv2 methods with the no-ssl2-method option.
     44 
     45   Major changes between OpenSSL 1.0.2f and OpenSSL 1.0.2g [1 Mar 2016]
     46 
     47       o Disable weak ciphers in SSLv3 and up in default builds of OpenSSL.
     48       o Disable SSLv2 default build, default negotiation and weak ciphers
     49         (CVE-2016-0800)
     50       o Fix a double-free in DSA code (CVE-2016-0705)
     51       o Disable SRP fake user seed to address a server memory leak
     52         (CVE-2016-0798)
     53       o Fix BN_hex2bn/BN_dec2bn NULL pointer deref/heap corruption
     54         (CVE-2016-0797)
     55       o Fix memory issues in BIO_*printf functions (CVE-2016-0799)
     56       o Fix side channel attack on modular exponentiation (CVE-2016-0702)
     57 
     58   Major changes between OpenSSL 1.0.2e and OpenSSL 1.0.2f [28 Jan 2016]
     59 
     60       o DH small subgroups (CVE-2016-0701)
     61       o SSLv2 doesn't block disabled ciphers (CVE-2015-3197)
     62 
     63   Major changes between OpenSSL 1.0.2d and OpenSSL 1.0.2e [3 Dec 2015]
     64 
     65       o BN_mod_exp may produce incorrect results on x86_64 (CVE-2015-3193)
     66       o Certificate verify crash with missing PSS parameter (CVE-2015-3194)
     67       o X509_ATTRIBUTE memory leak (CVE-2015-3195)
     68       o Rewrite EVP_DecodeUpdate (base64 decoding) to fix several bugs
     69       o In DSA_generate_parameters_ex, if the provided seed is too short,
     70         return an error
     71 
     72   Major changes between OpenSSL 1.0.2c and OpenSSL 1.0.2d [9 Jul 2015]
     73 
     74       o Alternate chains certificate forgery (CVE-2015-1793)
     75       o Race condition handling PSK identify hint (CVE-2015-3196)
     76 
     77   Major changes between OpenSSL 1.0.2b and OpenSSL 1.0.2c [12 Jun 2015]
     78 
     79       o Fix HMAC ABI incompatibility
     80 
     81   Major changes between OpenSSL 1.0.2a and OpenSSL 1.0.2b [11 Jun 2015]
     82 
     83       o Malformed ECParameters causes infinite loop (CVE-2015-1788)
     84       o Exploitable out-of-bounds read in X509_cmp_time (CVE-2015-1789)
     85       o PKCS7 crash with missing EnvelopedContent (CVE-2015-1790)
     86       o CMS verify infinite loop with unknown hash function (CVE-2015-1792)
     87       o Race condition handling NewSessionTicket (CVE-2015-1791)
     88 
     89   Major changes between OpenSSL 1.0.2 and OpenSSL 1.0.2a [19 Mar 2015]
     90 
     91       o OpenSSL 1.0.2 ClientHello sigalgs DoS fix (CVE-2015-0291)
     92       o Multiblock corrupted pointer fix (CVE-2015-0290)
     93       o Segmentation fault in DTLSv1_listen fix (CVE-2015-0207)
     94       o Segmentation fault in ASN1_TYPE_cmp fix (CVE-2015-0286)
     95       o Segmentation fault for invalid PSS parameters fix (CVE-2015-0208)
     96       o ASN.1 structure reuse memory corruption fix (CVE-2015-0287)
     97       o PKCS7 NULL pointer dereferences fix (CVE-2015-0289)
     98       o DoS via reachable assert in SSLv2 servers fix (CVE-2015-0293)
     99       o Empty CKE with client auth and DHE fix (CVE-2015-1787)
    100       o Handshake with unseeded PRNG fix (CVE-2015-0285)
    101       o Use After Free following d2i_ECPrivatekey error fix (CVE-2015-0209)
    102       o X509_to_X509_REQ NULL pointer deref fix (CVE-2015-0288)
    103       o Removed the export ciphers from the DEFAULT ciphers
    104 
    105   Major changes between OpenSSL 1.0.1l and OpenSSL 1.0.2 [22 Jan 2015]:
    106 
    107       o Suite B support for TLS 1.2 and DTLS 1.2
    108       o Support for DTLS 1.2
    109       o TLS automatic EC curve selection.
    110       o API to set TLS supported signature algorithms and curves
    111       o SSL_CONF configuration API.
    112       o TLS Brainpool support.
    113       o ALPN support.
    114       o CMS support for RSA-PSS, RSA-OAEP, ECDH and X9.42 DH.
    115 
    116   Major changes between OpenSSL 1.0.1k and OpenSSL 1.0.1l [15 Jan 2015]
    117 
    118       o Build fixes for the Windows and OpenVMS platforms
    119 
    120   Major changes between OpenSSL 1.0.1j and OpenSSL 1.0.1k [8 Jan 2015]
    121 
    122       o Fix for CVE-2014-3571
    123       o Fix for CVE-2015-0206
    124       o Fix for CVE-2014-3569
    125       o Fix for CVE-2014-3572
    126       o Fix for CVE-2015-0204
    127       o Fix for CVE-2015-0205
    128       o Fix for CVE-2014-8275
    129       o Fix for CVE-2014-3570
    130 
    131   Major changes between OpenSSL 1.0.1i and OpenSSL 1.0.1j [15 Oct 2014]
    132 
    133       o Fix for CVE-2014-3513
    134       o Fix for CVE-2014-3567
    135       o Mitigation for CVE-2014-3566 (SSL protocol vulnerability)
    136       o Fix for CVE-2014-3568
    137 
    138   Major changes between OpenSSL 1.0.1h and OpenSSL 1.0.1i [6 Aug 2014]
    139 
    140       o Fix for CVE-2014-3512
    141       o Fix for CVE-2014-3511
    142       o Fix for CVE-2014-3510
    143       o Fix for CVE-2014-3507
    144       o Fix for CVE-2014-3506
    145       o Fix for CVE-2014-3505
    146       o Fix for CVE-2014-3509
    147       o Fix for CVE-2014-5139
    148       o Fix for CVE-2014-3508
    149 
    150   Major changes between OpenSSL 1.0.1g and OpenSSL 1.0.1h [5 Jun 2014]
    151 
    152       o Fix for CVE-2014-0224
    153       o Fix for CVE-2014-0221
    154       o Fix for CVE-2014-0198
    155       o Fix for CVE-2014-0195
    156       o Fix for CVE-2014-3470
    157       o Fix for CVE-2010-5298
    158 
    159   Major changes between OpenSSL 1.0.1f and OpenSSL 1.0.1g [7 Apr 2014]
    160 
    161       o Fix for CVE-2014-0160
    162       o Add TLS padding extension workaround for broken servers.
    163       o Fix for CVE-2014-0076
    164 
    165   Major changes between OpenSSL 1.0.1e and OpenSSL 1.0.1f [6 Jan 2014]
    166 
    167       o Don't include gmt_unix_time in TLS server and client random values
    168       o Fix for TLS record tampering bug CVE-2013-4353
    169       o Fix for TLS version checking bug CVE-2013-6449
    170       o Fix for DTLS retransmission bug CVE-2013-6450
    171 
    172   Major changes between OpenSSL 1.0.1d and OpenSSL 1.0.1e [11 Feb 2013]:
    173 
    174       o Corrected fix for CVE-2013-0169
    175 
    176   Major changes between OpenSSL 1.0.1c and OpenSSL 1.0.1d [4 Feb 2013]:
    177 
    178       o Fix renegotiation in TLS 1.1, 1.2 by using the correct TLS version.
    179       o Include the fips configuration module.
    180       o Fix OCSP bad key DoS attack CVE-2013-0166
    181       o Fix for SSL/TLS/DTLS CBC plaintext recovery attack CVE-2013-0169
    182       o Fix for TLS AESNI record handling flaw CVE-2012-2686
    183 
    184   Major changes between OpenSSL 1.0.1b and OpenSSL 1.0.1c [10 May 2012]:
    185 
    186       o Fix TLS/DTLS record length checking bug CVE-2012-2333
    187       o Don't attempt to use non-FIPS composite ciphers in FIPS mode.
    188 
    189   Major changes between OpenSSL 1.0.1a and OpenSSL 1.0.1b [26 Apr 2012]:
    190 
    191       o Fix compilation error on non-x86 platforms.
    192       o Make FIPS capable OpenSSL ciphers work in non-FIPS mode.
    193       o Fix SSL_OP_NO_TLSv1_1 clash with SSL_OP_ALL in OpenSSL 1.0.0
    194 
    195   Major changes between OpenSSL 1.0.1 and OpenSSL 1.0.1a [19 Apr 2012]:
    196 
    197       o Fix for ASN1 overflow bug CVE-2012-2110
    198       o Workarounds for some servers that hang on long client hellos.
    199       o Fix SEGV in AES code.
    200 
    201   Major changes between OpenSSL 1.0.0h and OpenSSL 1.0.1 [14 Mar 2012]:
    202 
    203       o TLS/DTLS heartbeat support.
    204       o SCTP support.
    205       o RFC 5705 TLS key material exporter.
    206       o RFC 5764 DTLS-SRTP negotiation.
    207       o Next Protocol Negotiation.
    208       o PSS signatures in certificates, requests and CRLs.
    209       o Support for password based recipient info for CMS.
    210       o Support TLS v1.2 and TLS v1.1.
    211       o Preliminary FIPS capability for unvalidated 2.0 FIPS module.
    212       o SRP support.
    213 
    214   Major changes between OpenSSL 1.0.0g and OpenSSL 1.0.0h [12 Mar 2012]:
    215 
    216       o Fix for CMS/PKCS#7 MMA CVE-2012-0884
    217       o Corrected fix for CVE-2011-4619
    218       o Various DTLS fixes.
    219 
    220   Major changes between OpenSSL 1.0.0f and OpenSSL 1.0.0g [18 Jan 2012]:
    221 
    222       o Fix for DTLS DoS issue CVE-2012-0050
    223 
    224   Major changes between OpenSSL 1.0.0e and OpenSSL 1.0.0f [4 Jan 2012]:
    225 
    226       o Fix for DTLS plaintext recovery attack CVE-2011-4108
    227       o Clear block padding bytes of SSL 3.0 records CVE-2011-4576
    228       o Only allow one SGC handshake restart for SSL/TLS CVE-2011-4619
    229       o Check parameters are not NULL in GOST ENGINE CVE-2012-0027
    230       o Check for malformed RFC3779 data CVE-2011-4577
    231 
    232   Major changes between OpenSSL 1.0.0d and OpenSSL 1.0.0e [6 Sep 2011]:
    233 
    234       o Fix for CRL vulnerability issue CVE-2011-3207
    235       o Fix for ECDH crashes CVE-2011-3210
    236       o Protection against EC timing attacks.
    237       o Support ECDH ciphersuites for certificates using SHA2 algorithms.
    238       o Various DTLS fixes.
    239 
    240   Major changes between OpenSSL 1.0.0c and OpenSSL 1.0.0d [8 Feb 2011]:
    241 
    242       o Fix for security issue CVE-2011-0014
    243 
    244   Major changes between OpenSSL 1.0.0b and OpenSSL 1.0.0c [2 Dec 2010]:
    245 
    246       o Fix for security issue CVE-2010-4180
    247       o Fix for CVE-2010-4252
    248       o Fix mishandling of absent EC point format extension.
    249       o Fix various platform compilation issues.
    250       o Corrected fix for security issue CVE-2010-3864.
    251 
    252   Major changes between OpenSSL 1.0.0a and OpenSSL 1.0.0b [16 Nov 2010]:
    253 
    254       o Fix for security issue CVE-2010-3864.
    255       o Fix for CVE-2010-2939
    256       o Fix WIN32 build system for GOST ENGINE.
    257 
    258   Major changes between OpenSSL 1.0.0 and OpenSSL 1.0.0a [1 Jun 2010]:
    259 
    260       o Fix for security issue CVE-2010-1633.
    261       o GOST MAC and CFB fixes.
    262 
    263   Major changes between OpenSSL 0.9.8n and OpenSSL 1.0.0 [29 Mar 2010]:
    264 
    265       o RFC3280 path validation: sufficient to process PKITS tests.
    266       o Integrated support for PVK files and keyblobs.
    267       o Change default private key format to PKCS#8.
    268       o CMS support: able to process all examples in RFC4134
    269       o Streaming ASN1 encode support for PKCS#7 and CMS.
    270       o Multiple signer and signer add support for PKCS#7 and CMS.
    271       o ASN1 printing support.
    272       o Whirlpool hash algorithm added.
    273       o RFC3161 time stamp support.
    274       o New generalised public key API supporting ENGINE based algorithms.
    275       o New generalised public key API utilities.
    276       o New ENGINE supporting GOST algorithms.
    277       o SSL/TLS GOST ciphersuite support.
    278       o PKCS#7 and CMS GOST support.
    279       o RFC4279 PSK ciphersuite support.
    280       o Supported points format extension for ECC ciphersuites.
    281       o ecdsa-with-SHA224/256/384/512 signature types.
    282       o dsa-with-SHA224 and dsa-with-SHA256 signature types.
    283       o Opaque PRF Input TLS extension support.
    284       o Updated time routines to avoid OS limitations.
    285 
    286   Major changes between OpenSSL 0.9.8m and OpenSSL 0.9.8n [24 Mar 2010]:
    287 
    288       o CFB cipher definition fixes.
    289       o Fix security issues CVE-2010-0740 and CVE-2010-0433.
    290 
    291   Major changes between OpenSSL 0.9.8l and OpenSSL 0.9.8m [25 Feb 2010]:
    292 
    293       o Cipher definition fixes.
    294       o Workaround for slow RAND_poll() on some WIN32 versions.
    295       o Remove MD2 from algorithm tables.
    296       o SPKAC handling fixes.
    297       o Support for RFC5746 TLS renegotiation extension.
    298       o Compression memory leak fixed.
    299       o Compression session resumption fixed.
    300       o Ticket and SNI coexistence fixes.
    301       o Many fixes to DTLS handling. 
    302 
    303   Major changes between OpenSSL 0.9.8k and OpenSSL 0.9.8l [5 Nov 2009]:
    304 
    305       o Temporary work around for CVE-2009-3555: disable renegotiation.
    306 
    307   Major changes between OpenSSL 0.9.8j and OpenSSL 0.9.8k [25 Mar 2009]:
    308 
    309       o Fix various build issues.
    310       o Fix security issues (CVE-2009-0590, CVE-2009-0591, CVE-2009-0789)
    311 
    312   Major changes between OpenSSL 0.9.8i and OpenSSL 0.9.8j [7 Jan 2009]:
    313 
    314       o Fix security issue (CVE-2008-5077)
    315       o Merge FIPS 140-2 branch code.
    316 
    317   Major changes between OpenSSL 0.9.8g and OpenSSL 0.9.8h [28 May 2008]:
    318 
    319       o CryptoAPI ENGINE support.
    320       o Various precautionary measures.
    321       o Fix for bugs affecting certificate request creation.
    322       o Support for local machine keyset attribute in PKCS#12 files.
    323 
    324   Major changes between OpenSSL 0.9.8f and OpenSSL 0.9.8g [19 Oct 2007]:
    325 
    326       o Backport of CMS functionality to 0.9.8.
    327       o Fixes for bugs introduced with 0.9.8f.
    328 
    329   Major changes between OpenSSL 0.9.8e and OpenSSL 0.9.8f [11 Oct 2007]:
    330 
    331       o Add gcc 4.2 support.
    332       o Add support for AES and SSE2 assembly lanugauge optimization
    333         for VC++ build.
    334       o Support for RFC4507bis and server name extensions if explicitly 
    335         selected at compile time.
    336       o DTLS improvements.
    337       o RFC4507bis support.
    338       o TLS Extensions support.
    339 
    340   Major changes between OpenSSL 0.9.8d and OpenSSL 0.9.8e [23 Feb 2007]:
    341 
    342       o Various ciphersuite selection fixes.
    343       o RFC3779 support.
    344 
    345   Major changes between OpenSSL 0.9.8c and OpenSSL 0.9.8d [28 Sep 2006]:
    346 
    347       o Introduce limits to prevent malicious key DoS  (CVE-2006-2940)
    348       o Fix security issues (CVE-2006-2937, CVE-2006-3737, CVE-2006-4343)
    349       o Changes to ciphersuite selection algorithm
    350 
    351   Major changes between OpenSSL 0.9.8b and OpenSSL 0.9.8c [5 Sep 2006]:
    352 
    353       o Fix Daniel Bleichenbacher forged signature attack, CVE-2006-4339
    354       o New cipher Camellia
    355 
    356   Major changes between OpenSSL 0.9.8a and OpenSSL 0.9.8b [4 May 2006]:
    357 
    358       o Cipher string fixes.
    359       o Fixes for VC++ 2005.
    360       o Updated ECC cipher suite support.
    361       o New functions EVP_CIPHER_CTX_new() and EVP_CIPHER_CTX_free().
    362       o Zlib compression usage fixes.
    363       o Built in dynamic engine compilation support on Win32.
    364       o Fixes auto dynamic engine loading in Win32.
    365 
    366   Major changes between OpenSSL 0.9.8 and OpenSSL 0.9.8a [11 Oct 2005]:
    367 
    368       o Fix potential SSL 2.0 rollback, CVE-2005-2969
    369       o Extended Windows CE support
    370 
    371   Major changes between OpenSSL 0.9.7g and OpenSSL 0.9.8 [5 Jul 2005]:
    372 
    373       o Major work on the BIGNUM library for higher efficiency and to
    374         make operations more streamlined and less contradictory.  This
    375         is the result of a major audit of the BIGNUM library.
    376       o Addition of BIGNUM functions for fields GF(2^m) and NIST
    377         curves, to support the Elliptic Crypto functions.
    378       o Major work on Elliptic Crypto; ECDH and ECDSA added, including
    379         the use through EVP, X509 and ENGINE.
    380       o New ASN.1 mini-compiler that's usable through the OpenSSL
    381         configuration file.
    382       o Added support for ASN.1 indefinite length constructed encoding.
    383       o New PKCS#12 'medium level' API to manipulate PKCS#12 files.
    384       o Complete rework of shared library construction and linking
    385         programs with shared or static libraries, through a separate
    386         Makefile.shared.
    387       o Rework of the passing of parameters from one Makefile to another.
    388       o Changed ENGINE framework to load dynamic engine modules
    389         automatically from specifically given directories.
    390       o New structure and ASN.1 functions for CertificatePair.
    391       o Changed the ZLIB compression method to be stateful.
    392       o Changed the key-generation and primality testing "progress"
    393         mechanism to take a structure that contains the ticker
    394         function and an argument.
    395       o New engine module: GMP (performs private key exponentiation).
    396       o New engine module: VIA PadLOck ACE extension in VIA C3
    397         Nehemiah processors.
    398       o Added support for IPv6 addresses in certificate extensions.
    399         See RFC 1884, section 2.2.
    400       o Added support for certificate policy mappings, policy
    401         constraints and name constraints.
    402       o Added support for multi-valued AVAs in the OpenSSL
    403         configuration file.
    404       o Added support for multiple certificates with the same subject
    405         in the 'openssl ca' index file.
    406       o Make it possible to create self-signed certificates using
    407         'openssl ca -selfsign'.
    408       o Make it possible to generate a serial number file with
    409         'openssl ca -create_serial'.
    410       o New binary search functions with extended functionality.
    411       o New BUF functions.
    412       o New STORE structure and library to provide an interface to all
    413         sorts of data repositories.  Supports storage of public and
    414         private keys, certificates, CRLs, numbers and arbitrary blobs.
    415 	This library is unfortunately unfinished and unused withing
    416 	OpenSSL.
    417       o New control functions for the error stack.
    418       o Changed the PKCS#7 library to support one-pass S/MIME
    419         processing.
    420       o Added the possibility to compile without old deprecated
    421         functionality with the OPENSSL_NO_DEPRECATED macro or the
    422         'no-deprecated' argument to the config and Configure scripts.
    423       o Constification of all ASN.1 conversion functions, and other
    424         affected functions.
    425       o Improved platform support for PowerPC.
    426       o New FIPS 180-2 algorithms (SHA-224, -256, -384 and -512).
    427       o New X509_VERIFY_PARAM structure to support parametrisation
    428         of X.509 path validation.
    429       o Major overhaul of RC4 performance on Intel P4, IA-64 and
    430         AMD64.
    431       o Changed the Configure script to have some algorithms disabled
    432         by default.  Those can be explicitely enabled with the new
    433         argument form 'enable-xxx'.
    434       o Change the default digest in 'openssl' commands from MD5 to
    435         SHA-1.
    436       o Added support for DTLS.
    437       o New BIGNUM blinding.
    438       o Added support for the RSA-PSS encryption scheme
    439       o Added support for the RSA X.931 padding.
    440       o Added support for BSD sockets on NetWare.
    441       o Added support for files larger than 2GB.
    442       o Added initial support for Win64.
    443       o Added alternate pkg-config files.
    444 
    445   Major changes between OpenSSL 0.9.7l and OpenSSL 0.9.7m [23 Feb 2007]:
    446 
    447       o FIPS 1.1.1 module linking.
    448       o Various ciphersuite selection fixes.
    449 
    450   Major changes between OpenSSL 0.9.7k and OpenSSL 0.9.7l [28 Sep 2006]:
    451 
    452       o Introduce limits to prevent malicious key DoS  (CVE-2006-2940)
    453       o Fix security issues (CVE-2006-2937, CVE-2006-3737, CVE-2006-4343)
    454 
    455   Major changes between OpenSSL 0.9.7j and OpenSSL 0.9.7k [5 Sep 2006]:
    456 
    457       o Fix Daniel Bleichenbacher forged signature attack, CVE-2006-4339
    458 
    459   Major changes between OpenSSL 0.9.7i and OpenSSL 0.9.7j [4 May 2006]:
    460 
    461       o Visual C++ 2005 fixes.
    462       o Update Windows build system for FIPS.
    463 
    464   Major changes between OpenSSL 0.9.7h and OpenSSL 0.9.7i [14 Oct 2005]:
    465 
    466       o Give EVP_MAX_MD_SIZE it's old value, except for a FIPS build.
    467 
    468   Major changes between OpenSSL 0.9.7g and OpenSSL 0.9.7h [11 Oct 2005]:
    469 
    470       o Fix SSL 2.0 Rollback, CVE-2005-2969
    471       o Allow use of fixed-length exponent on DSA signing
    472       o Default fixed-window RSA, DSA, DH private-key operations
    473 
    474   Major changes between OpenSSL 0.9.7f and OpenSSL 0.9.7g [11 Apr 2005]:
    475 
    476       o More compilation issues fixed.
    477       o Adaptation to more modern Kerberos API.
    478       o Enhanced or corrected configuration for Solaris64, Mingw and Cygwin.
    479       o Enhanced x86_64 assembler BIGNUM module.
    480       o More constification.
    481       o Added processing of proxy certificates (RFC 3820).
    482 
    483   Major changes between OpenSSL 0.9.7e and OpenSSL 0.9.7f [22 Mar 2005]:
    484 
    485       o Several compilation issues fixed.
    486       o Many memory allocation failure checks added.
    487       o Improved comparison of X509 Name type.
    488       o Mandatory basic checks on certificates.
    489       o Performance improvements.
    490 
    491   Major changes between OpenSSL 0.9.7d and OpenSSL 0.9.7e [25 Oct 2004]:
    492 
    493       o Fix race condition in CRL checking code.
    494       o Fixes to PKCS#7 (S/MIME) code.
    495 
    496   Major changes between OpenSSL 0.9.7c and OpenSSL 0.9.7d [17 Mar 2004]:
    497 
    498       o Security: Fix Kerberos ciphersuite SSL/TLS handshaking bug
    499       o Security: Fix null-pointer assignment in do_change_cipher_spec()
    500       o Allow multiple active certificates with same subject in CA index
    501       o Multiple X509 verification fixes
    502       o Speed up HMAC and other operations
    503 
    504   Major changes between OpenSSL 0.9.7b and OpenSSL 0.9.7c [30 Sep 2003]:
    505 
    506       o Security: fix various ASN1 parsing bugs.
    507       o New -ignore_err option to OCSP utility.
    508       o Various interop and bug fixes in S/MIME code.
    509       o SSL/TLS protocol fix for unrequested client certificates.
    510 
    511   Major changes between OpenSSL 0.9.7a and OpenSSL 0.9.7b [10 Apr 2003]:
    512 
    513       o Security: counter the Klima-Pokorny-Rosa extension of
    514         Bleichbacher's attack 
    515       o Security: make RSA blinding default.
    516       o Configuration: Irix fixes, AIX fixes, better mingw support.
    517       o Support for new platforms: linux-ia64-ecc.
    518       o Build: shared library support fixes.
    519       o ASN.1: treat domainComponent correctly.
    520       o Documentation: fixes and additions.
    521 
    522   Major changes between OpenSSL 0.9.7 and OpenSSL 0.9.7a [19 Feb 2003]:
    523 
    524       o Security: Important security related bugfixes.
    525       o Enhanced compatibility with MIT Kerberos.
    526       o Can be built without the ENGINE framework.
    527       o IA32 assembler enhancements.
    528       o Support for new platforms: FreeBSD/IA64 and FreeBSD/Sparc64.
    529       o Configuration: the no-err option now works properly.
    530       o SSL/TLS: now handles manual certificate chain building.
    531       o SSL/TLS: certain session ID malfunctions corrected.
    532 
    533   Major changes between OpenSSL 0.9.6 and OpenSSL 0.9.7 [30 Dec 2002]:
    534 
    535       o New library section OCSP.
    536       o Complete rewrite of ASN1 code.
    537       o CRL checking in verify code and openssl utility.
    538       o Extension copying in 'ca' utility.
    539       o Flexible display options in 'ca' utility.
    540       o Provisional support for international characters with UTF8.
    541       o Support for external crypto devices ('engine') is no longer
    542         a separate distribution.
    543       o New elliptic curve library section.
    544       o New AES (Rijndael) library section.
    545       o Support for new platforms: Windows CE, Tandem OSS, A/UX, AIX 64-bit,
    546         Linux x86_64, Linux 64-bit on Sparc v9
    547       o Extended support for some platforms: VxWorks
    548       o Enhanced support for shared libraries.
    549       o Now only builds PIC code when shared library support is requested.
    550       o Support for pkg-config.
    551       o Lots of new manuals.
    552       o Makes symbolic links to or copies of manuals to cover all described
    553         functions.
    554       o Change DES API to clean up the namespace (some applications link also
    555         against libdes providing similar functions having the same name).
    556         Provide macros for backward compatibility (will be removed in the
    557         future).
    558       o Unify handling of cryptographic algorithms (software and engine)
    559         to be available via EVP routines for asymmetric and symmetric ciphers.
    560       o NCONF: new configuration handling routines.
    561       o Change API to use more 'const' modifiers to improve error checking
    562         and help optimizers.
    563       o Finally remove references to RSAref.
    564       o Reworked parts of the BIGNUM code.
    565       o Support for new engines: Broadcom ubsec, Accelerated Encryption
    566         Processing, IBM 4758.
    567       o A few new engines added in the demos area.
    568       o Extended and corrected OID (object identifier) table.
    569       o PRNG: query at more locations for a random device, automatic query for
    570         EGD style random sources at several locations.
    571       o SSL/TLS: allow optional cipher choice according to server's preference.
    572       o SSL/TLS: allow server to explicitly set new session ids.
    573       o SSL/TLS: support Kerberos cipher suites (RFC2712).
    574 	Only supports MIT Kerberos for now.
    575       o SSL/TLS: allow more precise control of renegotiations and sessions.
    576       o SSL/TLS: add callback to retrieve SSL/TLS messages.
    577       o SSL/TLS: support AES cipher suites (RFC3268).
    578 
    579   Major changes between OpenSSL 0.9.6j and OpenSSL 0.9.6k [30 Sep 2003]:
    580 
    581       o Security: fix various ASN1 parsing bugs.
    582       o SSL/TLS protocol fix for unrequested client certificates.
    583 
    584   Major changes between OpenSSL 0.9.6i and OpenSSL 0.9.6j [10 Apr 2003]:
    585 
    586       o Security: counter the Klima-Pokorny-Rosa extension of
    587         Bleichbacher's attack 
    588       o Security: make RSA blinding default.
    589       o Build: shared library support fixes.
    590 
    591   Major changes between OpenSSL 0.9.6h and OpenSSL 0.9.6i [19 Feb 2003]:
    592 
    593       o Important security related bugfixes.
    594 
    595   Major changes between OpenSSL 0.9.6g and OpenSSL 0.9.6h [5 Dec 2002]:
    596 
    597       o New configuration targets for Tandem OSS and A/UX.
    598       o New OIDs for Microsoft attributes.
    599       o Better handling of SSL session caching.
    600       o Better comparison of distinguished names.
    601       o Better handling of shared libraries in a mixed GNU/non-GNU environment.
    602       o Support assembler code with Borland C.
    603       o Fixes for length problems.
    604       o Fixes for uninitialised variables.
    605       o Fixes for memory leaks, some unusual crashes and some race conditions.
    606       o Fixes for smaller building problems.
    607       o Updates of manuals, FAQ and other instructive documents.
    608 
    609   Major changes between OpenSSL 0.9.6f and OpenSSL 0.9.6g [9 Aug 2002]:
    610 
    611       o Important building fixes on Unix.
    612 
    613   Major changes between OpenSSL 0.9.6e and OpenSSL 0.9.6f [8 Aug 2002]:
    614 
    615       o Various important bugfixes.
    616 
    617   Major changes between OpenSSL 0.9.6d and OpenSSL 0.9.6e [30 Jul 2002]:
    618 
    619       o Important security related bugfixes.
    620       o Various SSL/TLS library bugfixes.
    621 
    622   Major changes between OpenSSL 0.9.6c and OpenSSL 0.9.6d [9 May 2002]:
    623 
    624       o Various SSL/TLS library bugfixes.
    625       o Fix DH parameter generation for 'non-standard' generators.
    626 
    627   Major changes between OpenSSL 0.9.6b and OpenSSL 0.9.6c [21 Dec 2001]:
    628 
    629       o Various SSL/TLS library bugfixes.
    630       o BIGNUM library fixes.
    631       o RSA OAEP and random number generation fixes.
    632       o Object identifiers corrected and added.
    633       o Add assembler BN routines for IA64.
    634       o Add support for OS/390 Unix, UnixWare with gcc, OpenUNIX 8,
    635         MIPS Linux; shared library support for Irix, HP-UX.
    636       o Add crypto accelerator support for AEP, Baltimore SureWare,
    637         Broadcom and Cryptographic Appliance's keyserver
    638         [in 0.9.6c-engine release].
    639 
    640   Major changes between OpenSSL 0.9.6a and OpenSSL 0.9.6b [9 Jul 2001]:
    641 
    642       o Security fix: PRNG improvements.
    643       o Security fix: RSA OAEP check.
    644       o Security fix: Reinsert and fix countermeasure to Bleichbacher's
    645         attack.
    646       o MIPS bug fix in BIGNUM.
    647       o Bug fix in "openssl enc".
    648       o Bug fix in X.509 printing routine.
    649       o Bug fix in DSA verification routine and DSA S/MIME verification.
    650       o Bug fix to make PRNG thread-safe.
    651       o Bug fix in RAND_file_name().
    652       o Bug fix in compatibility mode trust settings.
    653       o Bug fix in blowfish EVP.
    654       o Increase default size for BIO buffering filter.
    655       o Compatibility fixes in some scripts.
    656 
    657   Major changes between OpenSSL 0.9.6 and OpenSSL 0.9.6a [5 Apr 2001]:
    658 
    659       o Security fix: change behavior of OpenSSL to avoid using
    660         environment variables when running as root.
    661       o Security fix: check the result of RSA-CRT to reduce the
    662         possibility of deducing the private key from an incorrectly
    663         calculated signature.
    664       o Security fix: prevent Bleichenbacher's DSA attack.
    665       o Security fix: Zero the premaster secret after deriving the
    666         master secret in DH ciphersuites.
    667       o Reimplement SSL_peek(), which had various problems.
    668       o Compatibility fix: the function des_encrypt() renamed to
    669         des_encrypt1() to avoid clashes with some Unixen libc.
    670       o Bug fixes for Win32, HP/UX and Irix.
    671       o Bug fixes in BIGNUM, SSL, PKCS#7, PKCS#12, X.509, CONF and
    672         memory checking routines.
    673       o Bug fixes for RSA operations in threaded environments.
    674       o Bug fixes in misc. openssl applications.
    675       o Remove a few potential memory leaks.
    676       o Add tighter checks of BIGNUM routines.
    677       o Shared library support has been reworked for generality.
    678       o More documentation.
    679       o New function BN_rand_range().
    680       o Add "-rand" option to openssl s_client and s_server.
    681 
    682   Major changes between OpenSSL 0.9.5a and OpenSSL 0.9.6 [10 Oct 2000]:
    683 
    684       o Some documentation for BIO and SSL libraries.
    685       o Enhanced chain verification using key identifiers.
    686       o New sign and verify options to 'dgst' application.
    687       o Support for DER and PEM encoded messages in 'smime' application.
    688       o New 'rsautl' application, low level RSA utility.
    689       o MD4 now included.
    690       o Bugfix for SSL rollback padding check.
    691       o Support for external crypto devices [1].
    692       o Enhanced EVP interface.
    693 
    694     [1] The support for external crypto devices is currently a separate
    695         distribution.  See the file README.ENGINE.
    696 
    697   Major changes between OpenSSL 0.9.5 and OpenSSL 0.9.5a [1 Apr 2000]:
    698 
    699       o Bug fixes for Win32, SuSE Linux, NeXTSTEP and FreeBSD 2.2.8 
    700       o Shared library support for HPUX and Solaris-gcc
    701       o Support of Linux/IA64
    702       o Assembler support for Mingw32
    703       o New 'rand' application
    704       o New way to check for existence of algorithms from scripts
    705 
    706   Major changes between OpenSSL 0.9.4 and OpenSSL 0.9.5 [25 May 2000]:
    707 
    708       o S/MIME support in new 'smime' command
    709       o Documentation for the OpenSSL command line application
    710       o Automation of 'req' application
    711       o Fixes to make s_client, s_server work under Windows
    712       o Support for multiple fieldnames in SPKACs
    713       o New SPKAC command line utilty and associated library functions
    714       o Options to allow passwords to be obtained from various sources
    715       o New public key PEM format and options to handle it
    716       o Many other fixes and enhancements to command line utilities
    717       o Usable certificate chain verification
    718       o Certificate purpose checking
    719       o Certificate trust settings
    720       o Support of authority information access extension
    721       o Extensions in certificate requests
    722       o Simplified X509 name and attribute routines
    723       o Initial (incomplete) support for international character sets
    724       o New DH_METHOD, DSA_METHOD and enhanced RSA_METHOD
    725       o Read only memory BIOs and simplified creation function
    726       o TLS/SSL protocol bugfixes: Accept TLS 'client hello' in SSL 3.0
    727         record; allow fragmentation and interleaving of handshake and other
    728         data
    729       o TLS/SSL code now "tolerates" MS SGC
    730       o Work around for Netscape client certificate hang bug
    731       o RSA_NULL option that removes RSA patent code but keeps other
    732         RSA functionality
    733       o Memory leak detection now allows applications to add extra information
    734         via a per-thread stack
    735       o PRNG robustness improved
    736       o EGD support
    737       o BIGNUM library bug fixes
    738       o Faster DSA parameter generation
    739       o Enhanced support for Alpha Linux
    740       o Experimental MacOS support
    741 
    742   Major changes between OpenSSL 0.9.3 and OpenSSL 0.9.4 [9 Aug 1999]:
    743 
    744       o Transparent support for PKCS#8 format private keys: these are used
    745         by several software packages and are more secure than the standard
    746         form
    747       o PKCS#5 v2.0 implementation
    748       o Password callbacks have a new void * argument for application data
    749       o Avoid various memory leaks
    750       o New pipe-like BIO that allows using the SSL library when actual I/O
    751         must be handled by the application (BIO pair)
    752 
    753   Major changes between OpenSSL 0.9.2b and OpenSSL 0.9.3 [24 May 1999]:
    754       o Lots of enhancements and cleanups to the Configuration mechanism
    755       o RSA OEAP related fixes
    756       o Added `openssl ca -revoke' option for revoking a certificate
    757       o Source cleanups: const correctness, type-safe stacks and ASN.1 SETs
    758       o Source tree cleanups: removed lots of obsolete files
    759       o Thawte SXNet, certificate policies and CRL distribution points
    760         extension support
    761       o Preliminary (experimental) S/MIME support
    762       o Support for ASN.1 UTF8String and VisibleString
    763       o Full integration of PKCS#12 code
    764       o Sparc assembler bignum implementation, optimized hash functions
    765       o Option to disable selected ciphers
    766 
    767   Major changes between OpenSSL 0.9.1c and OpenSSL 0.9.2b [22 Mar 1999]:
    768       o Fixed a security hole related to session resumption
    769       o Fixed RSA encryption routines for the p < q case
    770       o "ALL" in cipher lists now means "everything except NULL ciphers"
    771       o Support for Triple-DES CBCM cipher
    772       o Support of Optimal Asymmetric Encryption Padding (OAEP) for RSA
    773       o First support for new TLSv1 ciphers
    774       o Added a few new BIOs (syslog BIO, reliable BIO)
    775       o Extended support for DSA certificate/keys.
    776       o Extended support for Certificate Signing Requests (CSR)
    777       o Initial support for X.509v3 extensions
    778       o Extended support for compression inside the SSL record layer
    779       o Overhauled Win32 builds
    780       o Cleanups and fixes to the Big Number (BN) library
    781       o Support for ASN.1 GeneralizedTime
    782       o Splitted ASN.1 SETs from SEQUENCEs
    783       o ASN1 and PEM support for Netscape Certificate Sequences
    784       o Overhauled Perl interface
    785       o Lots of source tree cleanups.
    786       o Lots of memory leak fixes.
    787       o Lots of bug fixes.
    788 
    789   Major changes between SSLeay 0.9.0b and OpenSSL 0.9.1c [23 Dec 1998]:
    790       o Integration of the popular NO_RSA/NO_DSA patches
    791       o Initial support for compression inside the SSL record layer
    792       o Added BIO proxy and filtering functionality
    793       o Extended Big Number (BN) library
    794       o Added RIPE MD160 message digest
    795       o Addeed support for RC2/64bit cipher
    796       o Extended ASN.1 parser routines
    797       o Adjustations of the source tree for CVS
    798       o Support for various new platforms
    799 
    800